Announcement

Collapse
No announcement yet.

Bug Report Thread

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug Report Thread

    Please post all bugs reports using the following template:
    Code:
    Date:
    Version:
    What happened:
    What should have happened:
    Screenshot:
    Video (If Possible):
    

  • #2
    Date: 5/23/16
    Version: 1.00 (I think can't seem to bring up version but its the launch version since I never tried it in beta)
    What happened: Error gui with no text on launch of script with multiple start locations attempted (edge & ring of kin)
    What should have happened: Script should have started like the other scripts. (my prayer level is 56 since it looked like another beta user was getting a similar bug as me and you asked him that question)

    error code:
    at r.ALLATORI_DEMO(ScriptGui.java:119)
    at r.<init>(ScriptGui.java:31)
    at i.<init>(GildedAltar.java:27)
    at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at java.lang.Class.newInstance(Unknown Source)
    at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:15)
    at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:173)
    at com.epicbot.IIIIIiIIiIII.ALLATORIxDEMO(xzb:1049)
    at com.epicbot.IiiiIiIiIIIi.run(zcc:118)
    at java.lang.Thread.run(Unknown Source)

    Comment


    • #3
      Date: 5/24/2016
      Version: 1.00 Assumed ( i just downloaded it)
      What happened: Nothing, i clicked start script and error window displayed. Attempted to start from multiple locations (house, deamonhiem, ect.)
      What should have happened: I imagine the bot would run >.<
      Screenshot: fack.jpg

      [04:47:17] STDERR com.epicbot.iIIIIiiIiiiI: Component creation must be done on Event Dispatch Thread
      [04:47:17] STDERR at com.epicbot.iIiIIiiIIIiI.h(xq:2608)
      [04:47:17] STDERR at org.jvnet.substance.SubstancePanelUI.createUI(glb: 46)
      [04:47:17] STDERR at sun.reflect.GeneratedMethodAccessor10.invoke(Unkno wn Source)
      [04:47:17] STDERR at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
      [04:47:17] STDERR at java.lang.reflect.Method.invoke(Unknown Source)
      [04:47:17] STDERR at sun.reflect.misc.Trampoline.invoke(Unknown Source)
      [04:47:17] STDERR at sun.reflect.GeneratedMethodAccessor2.invoke(Unknow n Source)
      [04:47:17] STDERR at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
      [04:47:17] STDERR at java.lang.reflect.Method.invoke(Unknown Source)
      [04:47:17] STDERR at sun.reflect.misc.MethodUtil.invoke(Unknown Source)
      [04:47:17] STDERR at javax.swing.UIDefaults.getUI(Unknown Source)
      [04:47:17] STDERR at javax.swing.UIManager.getUI(Unknown Source)
      [04:47:17] STDERR at javax.swing.JPanel.updateUI(Unknown Source)
      [04:47:17] STDERR at javax.swing.JPanel.<init>(Unknown Source)
      [04:47:17] STDERR at javax.swing.JPanel.<init>(Unknown Source)
      [04:47:17] STDERR at javax.swing.JPanel.<init>(Unknown Source)
      [04:47:17] STDERR at r.ALLATORI_DEMO(ScriptGui.java:117)
      [04:47:17] STDERR at r.<init>(ScriptGui.java:31)
      [04:47:17] STDERR at i.<init>(GildedAltar.java:27)
      [04:47:17] STDERR at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
      [04:47:17] STDERR at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(Unknown Source)
      [04:47:17] STDERR at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(Unknown Source)
      [04:47:17] STDERR at java.lang.reflect.Constructor.newInstance(Unknown Source)
      [04:47:17] STDERR at java.lang.Class.newInstance0(Unknown Source)
      [04:47:17] STDERR at java.lang.Class.newInstance(Unknown Source)
      [04:47:17] STDERR at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:15)
      [04:47:17] STDERR at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:173)
      [04:47:17] STDERR at com.epicbot.IIIIIiIIiIII.ALLATORIxDEMO(xzb:1049)
      [04:47:17] STDERR at com.epicbot.IiiiIiIiIIIi.run(zcc:118)
      [04:47:17] STDERR at java.lang.Thread.run(Unknown Source)
      [04:47:17] STDERR UIDefaults.getUI() failed: createUI() failed for javax.swing.JPanel[,0,0,0x0,invalid,layout=java.awt.FlowLayout,alignm entX=0.0,alignmentY=0.0,border=,flags=9,maximumSiz e=,minimumSize=,preferredSize=] java.lang.reflect.InvocationTargetException
      [04:47:17] STDERR java.lang.Error
      [04:47:17] STDERR at javax.swing.UIDefaults.getUIError(Unknown Source)
      [04:47:17] STDERR at javax.swing.MultiUIDefaults.getUIError(Unknown Source)
      [04:47:17] STDERR at javax.swing.UIDefaults.getUI(Unknown Source)
      [04:47:17] STDERR at javax.swing.UIManager.getUI(Unknown Source)
      [04:47:17] STDERR at javax.swing.JPanel.updateUI(Unknown Source)
      [04:47:17] STDERR at javax.swing.JPanel.<init>(Unknown Source)
      [04:47:17] STDERR at javax.swing.JPanel.<init>(Unknown Source)
      [04:47:17] STDERR at javax.swing.JPanel.<init>(Unknown Source)
      [04:47:17] STDERR at r.ALLATORI_DEMO(ScriptGui.java:117)
      [04:47:17] STDERR at r.<init>(ScriptGui.java:31)
      [04:47:17] STDERR at i.<init>(GildedAltar.java:27)
      [04:47:17] STDERR at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
      [04:47:17] STDERR at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(Unknown Source)
      [04:47:17] STDERR at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(Unknown Source)
      [04:47:17] STDERR at java.lang.reflect.Constructor.newInstance(Unknown Source)
      [04:47:17] STDERR at java.lang.Class.newInstance0(Unknown Source)
      [04:47:17] STDERR at java.lang.Class.newInstance(Unknown Source)
      [04:47:17] STDERR at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:15)
      [04:47:17] STDERR at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:173)
      [04:47:17] STDERR at com.epicbot.IIIIIiIIiIII.ALLATORIxDEMO(xzb:1049)
      [04:47:17] STDERR at com.epicbot.IiiiIiIiIIIi.run(zcc:118)
      [04:47:17] STDERR at java.lang.Thread.run(Unknown Source)
      [04:47:17] Internal Unable to start script java.lang.NullPointerException
      at r.ALLATORI_DEMO(ScriptGui.java:119)
      at r.<init>(ScriptGui.java:31)
      at i.<init>(GildedAltar.java:27)
      at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(Unknown Source)
      at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(Unknown Source)
      at java.lang.reflect.Constructor.newInstance(Unknown Source)
      at java.lang.Class.newInstance0(Unknown Source)
      at java.lang.Class.newInstance(Unknown Source)
      at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:15)
      at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:173)
      at com.epicbot.IIIIIiIIiIII.ALLATORIxDEMO(xzb:1049)
      at com.epicbot.IiiiIiIiIIIi.run(zcc:118)
      at java.lang.Thread.run(Unknown Source)

      Comment


      • #4
        Originally posted by SingersSword View Post
        Date: 5/24/2016
        Version: 1.00 Assumed ( i just downloaded it)
        What happened: Nothing, i clicked start script and error window displayed. Attempted to start from multiple locations (house, deamonhiem, ect.)
        What should have happened: I imagine the bot would run >.<
        Screenshot: [ATTACH=CONFIG]7504[/ATTACH]

        [04:47:17] STDERR com.epicbot.iIIIIiiIiiiI: Component creation must be done on Event Dispatch Thread
        [04:47:17] STDERR at com.epicbot.iIiIIiiIIIiI.h(xq:2608)
        [04:47:17] STDERR at org.jvnet.substance.SubstancePanelUI.createUI(glb: 46)
        [04:47:17] STDERR at sun.reflect.GeneratedMethodAccessor10.invoke(Unkno wn Source)
        [04:47:17] STDERR at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
        [04:47:17] STDERR at java.lang.reflect.Method.invoke(Unknown Source)
        [04:47:17] STDERR at sun.reflect.misc.Trampoline.invoke(Unknown Source)
        [04:47:17] STDERR at sun.reflect.GeneratedMethodAccessor2.invoke(Unknow n Source)
        [04:47:17] STDERR at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
        [04:47:17] STDERR at java.lang.reflect.Method.invoke(Unknown Source)
        [04:47:17] STDERR at sun.reflect.misc.MethodUtil.invoke(Unknown Source)
        [04:47:17] STDERR at javax.swing.UIDefaults.getUI(Unknown Source)
        [04:47:17] STDERR at javax.swing.UIManager.getUI(Unknown Source)
        [04:47:17] STDERR at javax.swing.JPanel.updateUI(Unknown Source)
        [04:47:17] STDERR at javax.swing.JPanel.<init>(Unknown Source)
        [04:47:17] STDERR at javax.swing.JPanel.<init>(Unknown Source)
        [04:47:17] STDERR at javax.swing.JPanel.<init>(Unknown Source)
        [04:47:17] STDERR at r.ALLATORI_DEMO(ScriptGui.java:117)
        [04:47:17] STDERR at r.<init>(ScriptGui.java:31)
        [04:47:17] STDERR at i.<init>(GildedAltar.java:27)
        [04:47:17] STDERR at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
        [04:47:17] STDERR at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(Unknown Source)
        [04:47:17] STDERR at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(Unknown Source)
        [04:47:17] STDERR at java.lang.reflect.Constructor.newInstance(Unknown Source)
        [04:47:17] STDERR at java.lang.Class.newInstance0(Unknown Source)
        [04:47:17] STDERR at java.lang.Class.newInstance(Unknown Source)
        [04:47:17] STDERR at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:15)
        [04:47:17] STDERR at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:173)
        [04:47:17] STDERR at com.epicbot.IIIIIiIIiIII.ALLATORIxDEMO(xzb:1049)
        [04:47:17] STDERR at com.epicbot.IiiiIiIiIIIi.run(zcc:118)
        [04:47:17] STDERR at java.lang.Thread.run(Unknown Source)
        [04:47:17] STDERR UIDefaults.getUI() failed: createUI() failed for javax.swing.JPanel[,0,0,0x0,invalid,layout=java.awt.FlowLayout,alignm entX=0.0,alignmentY=0.0,border=,flags=9,maximumSiz e=,minimumSize=,preferredSize=] java.lang.reflect.InvocationTargetException
        [04:47:17] STDERR java.lang.Error
        [04:47:17] STDERR at javax.swing.UIDefaults.getUIError(Unknown Source)
        [04:47:17] STDERR at javax.swing.MultiUIDefaults.getUIError(Unknown Source)
        [04:47:17] STDERR at javax.swing.UIDefaults.getUI(Unknown Source)
        [04:47:17] STDERR at javax.swing.UIManager.getUI(Unknown Source)
        [04:47:17] STDERR at javax.swing.JPanel.updateUI(Unknown Source)
        [04:47:17] STDERR at javax.swing.JPanel.<init>(Unknown Source)
        [04:47:17] STDERR at javax.swing.JPanel.<init>(Unknown Source)
        [04:47:17] STDERR at javax.swing.JPanel.<init>(Unknown Source)
        [04:47:17] STDERR at r.ALLATORI_DEMO(ScriptGui.java:117)
        [04:47:17] STDERR at r.<init>(ScriptGui.java:31)
        [04:47:17] STDERR at i.<init>(GildedAltar.java:27)
        [04:47:17] STDERR at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
        [04:47:17] STDERR at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(Unknown Source)
        [04:47:17] STDERR at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(Unknown Source)
        [04:47:17] STDERR at java.lang.reflect.Constructor.newInstance(Unknown Source)
        [04:47:17] STDERR at java.lang.Class.newInstance0(Unknown Source)
        [04:47:17] STDERR at java.lang.Class.newInstance(Unknown Source)
        [04:47:17] STDERR at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:15)
        [04:47:17] STDERR at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:173)
        [04:47:17] STDERR at com.epicbot.IIIIIiIIiIII.ALLATORIxDEMO(xzb:1049)
        [04:47:17] STDERR at com.epicbot.IiiiIiIiIIIi.run(zcc:118)
        [04:47:17] STDERR at java.lang.Thread.run(Unknown Source)
        [04:47:17] Internal Unable to start script java.lang.NullPointerException
        at r.ALLATORI_DEMO(ScriptGui.java:119)
        at r.<init>(ScriptGui.java:31)
        at i.<init>(GildedAltar.java:27)
        at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at java.lang.Class.newInstance0(Unknown Source)
        at java.lang.Class.newInstance(Unknown Source)
        at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:15)
        at com.epicbot.IIiiIiIiIIIi.ALLATORIxDEMO(xzb:173)
        at com.epicbot.IIIIIiIIiIII.ALLATORIxDEMO(xzb:1049)
        at com.epicbot.IiiiIiIiIIIi.run(zcc:118)
        at java.lang.Thread.run(Unknown Source)
        That's definitely odd... I just tried it again and it's working without issue for me. I will take a look into on this end and see what I can find. In the meantime, could you get a screenshot of the script settings you are attempting to use and your graphics settings?

        EDIT:
        It appears this issue only occurs when you are attempting to run the script on Windows, which would explain why I never encountered this issue as I develop on OSX. I will work on getting a fix out for this as soon as possible.

        On a side note, the version number is displayed in the bottom-right corner of the script paint
        Attached Files
        Last edited by Doomboy; 05-25-2016, 01:14 PM.

        Comment


        • #5
          I just pushed a fix that should resolve the issue with the script crashing at start up on Windows.

          Comment


          • #6
            Date: 5/29/16
            Version: 1.01
            What happened: Script stops executing. Just stands there at certain moments. Sometimes it stops working during bank or during teleporting. "Waiting" status is where it stops working.
            What should have happened: Continue next events.
            Screenshot:bug.jpg

            Video (If Possible):

            Comment


            • #7
              there seems to be a problem as the script doesnt want to use the mounted amulet of glory to teleport to bank however ring of kinship works

              Comment


              • #8
                Originally posted by taran93 View Post
                there seems to be a problem as the script doesnt want to use the mounted amulet of glory to teleport to bank however ring of kinship works
                I've tried to use ring of kinship too. It would randomly stop working sometimes. The status would continually say waiting.

                Comment


                • #9
                  Originally posted by theMan812 View Post
                  Date: 5/29/16
                  Version: 1.01
                  What happened: Script stops executing. Just stands there at certain moments. Sometimes it stops working during bank or during teleporting. "Waiting" status is where it stops working.
                  What should have happened: Continue next events.
                  Screenshot:[ATTACH=CONFIG]7511[/ATTACH]

                  Video (If Possible):
                  Does the script hang up after using all the remains? Also, if you manually move the camera around does the script resume what it's doing? If you could get a video showing the script hanging up that would definitely go a long way towards me fixing it.

                  Comment


                  • #10
                    You spelled "infernal" wrong. it's spelled "inferal." Awesome script btw. Not sure if you have a progress thread or anything but you're more than welcome to use this. proguilded alter.JPG

                    Comment


                    • #11
                      Originally posted by SingersSword View Post
                      You spelled "infernal" wrong. it's spelled "inferal." Awesome script btw. Not sure if you have a progress thread or anything but you're more than welcome to use this. [ATTACH=CONFIG]7512[/ATTACH]
                      Glad to hear you are enjoying the script. Also, thanks for pointing that out, I'll go back and change it now though it likely won't get pushed out until the next version. Also, could you post that progress report here: https://forum.epicbot.com/showthread...ports&p=513794

                      Comment


                      • #12
                        keeps stopping outside of the bank when using ring of kinship and logs out after about 30 mins of usage, and also house glory is still not working? do we have at ETA on the fix? many thanks

                        Comment


                        • #13
                          Originally posted by taran93 View Post
                          keeps stopping outside of the bank when using ring of kinship and logs out after about 30 mins of usage, and also house glory is still not working? do we have at ETA on the fix? many thanks
                          Could you provide a little more detail such as the last message written out to the log window before it logs out, script settings, GUI settings, whether it withdraws the required items before stopping when using the Ring of Kinship? Also, after I didn't hear back from anyone when I inquired about more details in regards to the Mounted Amulet teleport not working, I assumed it was fixed, as I just used both methods without issue for 30+ minutes each. If you could get a video of either of these two bugs occurring, it would go a long way towards resolving them.

                          Comment


                          • #14
                            Date: 6/15/16
                            Version: Unknown
                            What happened: It burns two herbs on one burner.
                            What should have happened: It should burn one herb on the bottom burner and one herb on the top, then bury bones on alter.
                            Screenshot:
                            Video (If Possible):

                            Comment


                            • #15
                              you must be doing something wrong [MENTION=815720]djbarnick[/MENTION] .. i bought it today, works flawlessly..

                              Actually,
                              This script is the best working script currently on EB
                              [MENTION=190139]Doomboy[/MENTION] You have done something great here!

                              i have somewhere of 10-20 pro scripts.. so i know what im talking about

                              Comment

                              Working...
                              X